Ubuntu – Teamviewer 8 – lsb_release crashed with IOError in getstatusoutput(): [Errno 10] No child processes


ubuntu-logo

I installed Teamviewer 8 on Ubuntu 12.04 (Precise) today and started getting frequent random internal error messages.

ubuntu-internal-error
Sorry, Ubuntu 12.04 has experienced an internal error.

I did not capture all of the details but this portion led me to a solution when I searched for it:

lsb_release crashed with IOError in getstatusoutput(): [Errno 10] No child processes

To fix the error first open the Terminal.

Next change directory to /opt/teamviewer8/tv_bin/script:

cd /opt/teamviewer8/tv_bin/script

Make a backup copy of tvw_main:

sudo cp tvw_main tvw_main.bak

Open tvw_main in the nano text editor:

sudo nano tvw_main

Edit the file as per the screenshot below:

teamviewer-tvw_main

  • comment out lsb_release -a
  • comment out lsb_release -ds > “$WINEPREFIX/drive_c/distrelease”

After make_path “$WINEPREFIX/drive_c” make a new line and paste the following:

cat /etc/lsb-release | grep DESCRIPTION | cut -f2 -d= | sed 's/\"//g' >     "$WINEPREFIX/drive_c/distrelease"

Save tvw_main and exit nano – Ctrl + O, Enter, Ctrl +X.

Source: https://bugs.launchpad.net/ubuntu/+source/lsb/+bug/1094218

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s